Architecture for Voice, Video and Integrated Data

Cisco Unified Communications

Problema ao atualizar CallManager 8.5.1 para 8.6.2 – SIP Normalization script vcs-interop

Posted by Paulo Souza em 01/07/2013


Pessoal,

Recentemente tive um problema bastante bizarro quando estava atualizando um CallManager versão 8.5.1 para versão 8.6.2. Imagino que nenhum de vocês já tenham visto este problema, porque é uma restrição muito específica que não acontece quando atualizando um CallManager comum de telefonia, o problema é mais relacionado a atualização de CallManager de telepresença integrado com VCS (Video Communication Server). Continuem lendo.  =)

O problema

Eu peguei um CallManager versão 8.5.1 que era usado para telepresença e com integração com VCS via SIP Trunk. Provavelmente a maioria não saiba, mas para integrar o VCS com o CallManager é recomendado criar um SIP Trunk customizado cheio de frescuras e detalhes. Um dos pontos a se configurar, a partir da versão 8.5.1, é aplicar um SIP normalization script no trunk chamado vcs-interop. Este script não vem criado por padrão na versão 8.5.1 do CallManager, apenas na 8.6.2, então é necessário adicioná-lo manualmente. Pois bem, o CallManager possuía este SIP normalization script criado e aplicado no trunk (eu mesmo tinha feito isso). Pois bem, quando fui atualizar o callmanager da versão 8.5.1 para a versão 8.6.2, tudo parecia correr bem como das outras vezes que atualizei usando as mesmas versões (acho que foram 2 vezes), eu estava sentado em frente ao monitor hipnotizado por aquelas barrinhas lentas carregando, então de repente, durante a execução dos scripts de instalação… … … … … Bum!! Tela azul!! A instalação falhou e recebi uma mensagem de erro bastante inútil, algo do tipo “Falha inesperada na atualização. Tentando reverter sistema para versão anterior…” Então o CallManager reiniciou e voltou com a versão 8.5.1 (pelo menos voltou rsrs).

Depois de outras tentativas, obtive exatamente o mesmo erro bizarro! Antes que eu terminasse de arrancar os meus cabelos, notei que a única diferença deste CallManager para os outros que eu tinha atualizado usando as mesmas versões era o bendito SIP normalization script vcs-interop. Pois bem, abri o release notes da versão 8.6.1, apertei CTRL+F e digitei “vcs-interop”, me deparei com a seguinte observação:

“If you are upgrading to Cisco Unified Communications Manager 8.6.1 from an earlier release, and your previous network included a connection to a Cisco TelePresence Video Communications Server (VCS), the upgrade to 8.6.1 will fail if the name of the SIP normalization script used in your previous release was vcs-interop. In this case, you must rename the old script prior to completing the upgrade.”

Bom, acho que nem preciso dizer mais nada. Apaguei o SIP normalization script e atualização rodou bonito, deu até gosto de ver aquelas barrinhas carregando.  =P

Acontece que na versão 8.6.2 do CallManager este script já vem criado por padrão, então quando o setup de instalação tentar criar o script, ele falha porque o objeto já existe na base de dados, então a atualização é abortada (estilo tela azul do Windows) e o sistema faz roll back para a versão anterior, neste caso, 8.5.1. Comportamento meio estranho, não é? Se o objeto já existe, deveria subscrevê-lo ou ignorá-lo, mas abortar a instalação!? =O

Workaround

Chorar. Ou pesquisar uma solução no blog AVVID.  =)

Solução

Deletar ou renomear o SIP normalization script vcs-interop antes de prosseguir com a atualização.

Aposto que eu fui a única pessoa no mundo que pegou este problema, duvido que mais alguém tenha tanto azar. =/

 

Até a próxima!

 

Paulo Souza

Anúncios

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

 
%d blogueiros gostam disto: